package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-zA-Z][\w+-._]+)@([\w_\-.]+[a-zA-Z])$`)
var str = `Flor1_m+hida-lgo.b@1g_mail.com
richie@cc.gatech.edu`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}