$re = '/^([a-zA-Z][\w+-._]+)@([\w_\-.]+[a-zA-Z])$/m';
$str = 'Flor1_m+hida-lgo.b@1g_mail.com
richie@cc.gatech.edu';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);