// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-zA-Z][\w+-._]+)@([\w_\-.]+[a-zA-Z])$").unwrap();
let string = "Flor1_m+hida-lgo.b@1g_mail.com
richie@cc.gatech.edu";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}