const regex = new RegExp('^([a-zA-Z][\\w+-._]+)@([\\w_\\-.]+[a-zA-Z])$', 'gm')
const str = `Flor1_m+hida-lgo.b@1g_mail.com
richie@cc.gatech.edu`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}