re = /^([a-zA-Z][\w+-._]+)@([\w_\-.]+[a-zA-Z])$/m
str = 'Flor1_m+hida-lgo.b@1g_mail.com
richie@cc.gatech.edu'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end