const regex = new RegExp(' ((?:#[\\w\\d\\-\\_\\ \\t]*)+)(@[\\w\\d\\-\\_\\.\\,\\!\\?\\ \\t\\:\\;\\%\\+\\(\\)\\\\\\/\\\\'\\"\\`\\%\\$]*)?$', 'gmu')
const str = `ls -la #
ls -la #1
ls -la #2#2
ls -la #1#2#3 @München
ls -la #1# 2#3 @München
ls -la #1# 2 #3 @München
ls -la #1#2 @desc
ls -la #@desc
echo \\#toignore #1
echo "#toignore" #1-2
echo "#toignore" #@desc
ls -la#toignore
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}