import re
regex = re.compile(r" ((?:#[\w\d\-\_\ \t]*)+)(@[\w\d\-\_\.\,\!\?\ \t\:\;\%\+\(\)\\\/\'\"\`\%\$]*)?$", flags=re.MULTILINE | re.UNICODE)
test_str = ("ls -la #\n"
"ls -la #1\n"
"ls -la #2#2\n"
"ls -la #1#2#3 @München\n"
"ls -la #1# 2#3 @München\n"
"ls -la #1# 2 #3 @München\n"
"ls -la #1#2 @desc \n"
"ls -la #@desc \n"
"echo \\#toignore #1\n"
"echo \"#toignore\" #1-2\n"
"echo \"#toignore\" #@desc\n"
"ls -la#toignore\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")