use strict;
my $str = '.htaccess
.gitignore
index.html
gruntfile.js';
my $regex = qr/\.(.+)$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";