re = /\.(.+)$/m
str = '.htaccess
.gitignore
index.html
gruntfile.js'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result