$re = '/\.(.+)$/m';
$str = '.htaccess
.gitignore
index.html
gruntfile.js';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;