package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:
(^(?:[^\nA-Z]+-)?)
|
((?:-[^\nA-Z]+|(?<![^\nA-Z]))$)
|
((?:[^\nA-Z]*)?[A-Z])
)`)
var str = `foo-ABcmCD-bar
DEF
WHATEVER-foo
foo-ABC-bar
ABC-bar
ABcmC
foo-abCD
abCD`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}