import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\n"
+ " (^(?:[^\\nA-Z]+-)?)\n"
+ "|\n"
+ " ((?:-[^\\nA-Z]+|(?<![^\\nA-Z]))$)\n"
+ "|\n"
+ " ((?:[^\\nA-Z]*)?[A-Z])\n"
+ ")";
final String string = "foo-ABcmCD-bar\n"
+ "DEF\n"
+ "WHATEVER-foo\n"
+ "foo-ABC-bar\n"
+ "ABC-bar\n"
+ "ABcmC\n"
+ "foo-abCD\n"
+ "abCD";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}