re = /(?:
(^(?:[^\nA-Z]+-)?)
|
((?:-[^\nA-Z]+|(?<![^\nA-Z]))$)
|
((?:[^\nA-Z]*)?[A-Z])
)/mx
str = 'foo-ABcmCD-bar
DEF
WHATEVER-foo
foo-ABC-bar
ABC-bar
ABcmC
foo-abCD
abCD'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end