$re = '/(?:
(^(?:[^\nA-Z]+-)?)
|
((?:-[^\nA-Z]+|(?<![^\nA-Z]))$)
|
((?:[^\nA-Z]*)?[A-Z])
)/mx';
$str = 'foo-ABcmCD-bar
DEF
WHATEVER-foo
foo-ABC-bar
ABC-bar
ABcmC
foo-abCD
abCD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);