# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:(^(?:\s*)\\/{4,}\n)+(^(\s*)\\/{2,3}(?!\\/)[\s\S]*\n)*\1)/$3\/**\n$2$3 *\/\n/gm;t' <<< "namespace sf {
////////////////////////////////////////////////////////////
/// \ingroup system
/// \brief Return a pointer to the Android native activity
///
/// You shouldn't have to use this function, unless you want
/// to implement very specific details, that SFML doesn't
/// support, or to use a workaround for a known issue.
///
/// \return Pointer to Android native activity structure
///
/// \sfplatform{Android,SFML/System/NativeActivity.hpp}
///
////////////////////////////////////////////////////////////
SFML_SYSTEM_API ANativeActivity* getNativeActivity();
////////////////////////////////////////////////////////////
// a
////////////////////////////////////////////////////////////
} // namespace sf"