$re = '/(?:(^(?:\s*)\/{4,}\n)+(^(\s*)\/{2,3}(?!\/)[\s\S]*\n)*\1)/m';
$str = 'namespace sf {
////////////////////////////////////////////////////////////
/// \\ingroup system
/// \\brief Return a pointer to the Android native activity
///
/// You shouldn\'t have to use this function, unless you want
/// to implement very specific details, that SFML doesn\'t
/// support, or to use a workaround for a known issue.
///
/// \\return Pointer to Android native activity structure
///
/// \\sfplatform{Android,SFML/System/NativeActivity.hpp}
///
////////////////////////////////////////////////////////////
SFML_SYSTEM_API ANativeActivity* getNativeActivity();
////////////////////////////////////////////////////////////
// a
////////////////////////////////////////////////////////////
} // namespace sf';
$subst = "$3/**\n$2$3 */\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;