#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:(^(?:\s*)\/{4,}\n)+(^(\s*)\/{2,3}(?!\/)[\s\S]*\n)*\1)"
Local $sString = "namespace sf {" & @CRLF & _
"////////////////////////////////////////////////////////////" & @CRLF & _
"/// \ingroup system" & @CRLF & _
"/// \brief Return a pointer to the Android native activity" & @CRLF & _
"/// " & @CRLF & _
"/// You shouldn't have to use this function, unless you want" & @CRLF & _
"/// to implement very specific details, that SFML doesn't" & @CRLF & _
"/// support, or to use a workaround for a known issue." & @CRLF & _
"///" & @CRLF & _
"/// \return Pointer to Android native activity structure" & @CRLF & _
"///" & @CRLF & _
"/// \sfplatform{Android,SFML/System/NativeActivity.hpp}" & @CRLF & _
"///" & @CRLF & _
"////////////////////////////////////////////////////////////" & @CRLF & _
"SFML_SYSTEM_API ANativeActivity* getNativeActivity();" & @CRLF & _
"" & @CRLF & _
" ////////////////////////////////////////////////////////////" & @CRLF & _
" // a " & @CRLF & _
" ////////////////////////////////////////////////////////////" & @CRLF & _
"" & @CRLF & _
"} // namespace sf"
Local $sSubst = "$3/**\n$2$3 */\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)