const regex = /(?:(^(?:\s*)\/{4,}\n)+(^(\s*)\/{2,3}(?!\/)[\s\S]*\n)*\1)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(^(?:\\s*)\\\/{4,}\\n)+(^(\\s*)\\\/{2,3}(?!\\\/)[\\s\\S]*\\n)*\\1)', 'gm')
const str = `namespace sf {
////////////////////////////////////////////////////////////
/// \\ingroup system
/// \\brief Return a pointer to the Android native activity
///
/// You shouldn't have to use this function, unless you want
/// to implement very specific details, that SFML doesn't
/// support, or to use a workaround for a known issue.
///
/// \\return Pointer to Android native activity structure
///
/// \\sfplatform{Android,SFML/System/NativeActivity.hpp}
///
////////////////////////////////////////////////////////////
SFML_SYSTEM_API ANativeActivity* getNativeActivity();
////////////////////////////////////////////////////////////
// a
////////////////////////////////////////////////////////////
} // namespace sf`;
const subst = `$3/**\n$2$3 */\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);