import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(^(?:\\s*)\\/{4,}\\n)+(^(\\s*)\\/{2,3}(?!\\/)[\\s\\S]*\\n)*\\1)";
final String string = "namespace sf {\n"
+ "////////////////////////////////////////////////////////////\n"
+ "/// \\ingroup system\n"
+ "/// \\brief Return a pointer to the Android native activity\n"
+ "/// \n"
+ "/// You shouldn't have to use this function, unless you want\n"
+ "/// to implement very specific details, that SFML doesn't\n"
+ "/// support, or to use a workaround for a known issue.\n"
+ "///\n"
+ "/// \\return Pointer to Android native activity structure\n"
+ "///\n"
+ "/// \\sfplatform{Android,SFML/System/NativeActivity.hpp}\n"
+ "///\n"
+ "////////////////////////////////////////////////////////////\n"
+ "SFML_SYSTEM_API ANativeActivity* getNativeActivity();\n\n"
+ " ////////////////////////////////////////////////////////////\n"
+ " // a \n"
+ " ////////////////////////////////////////////////////////////\n\n"
+ "} // namespace sf";
final String subst = "$3/**\\n$2$3 */\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}