using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?>.*?)(nugenix|cialis|somethingelse)(?>.*?@)(?!.*?(nugenix|cialis|somethingelse))";
string input = @"// Match
Return-Path: <get-some-nugenix-for-health@whatever.yooooo.com>
Return-Path: <get-some-nugenix@-sakana15.com>
Return-Path: <nugenix-for-health@-sakana15.com>
<anycharacters+somethingelse+anyothercharacters+@
// No match - Banned words in Sender and Domain
Return-Path: <get-some-nugenix-for-health@whatnugenixever.yooooo.com>
Return-Path: <get-some-nugenix-for-health@nugenixwhatever.yooooo.com>
Return-Path: <get-some-nugenix-for-health@whatever.yooooo.comnugenix>
Return-Path: <get-some--for-healthnugenix@whatnugenixever.yooooo.com>
Return-Path: <nugenixget-some-for-health@nugenixwhatever.yooooo.com>
// No Match - Banned words only in domain
Return-Path: <get-some-for-health@whatever.yooooo.com>
Return-Path: <get-some-for-health@nugenixwhatever.yooooo.com>
Return-Path: <get-some-for-health@whatevernugenix.yooooo.com>
Return-Path: <get-some-for-health@whatever.yooooo.comnugenix>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}