import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?>.*?)(nugenix|cialis|somethingelse)(?>.*?@)(?!.*?(nugenix|cialis|somethingelse))";
final String string = "// Match\n"
+ "Return-Path: <get-some-nugenix-for-health@whatever.yooooo.com>\n"
+ "Return-Path: <get-some-nugenix@-sakana15.com>\n"
+ "Return-Path: <nugenix-for-health@-sakana15.com>\n"
+ "<anycharacters+somethingelse+anyothercharacters+@\n\n"
+ "// No match - Banned words in Sender and Domain\n"
+ "Return-Path: <get-some-nugenix-for-health@whatnugenixever.yooooo.com>\n"
+ "Return-Path: <get-some-nugenix-for-health@nugenixwhatever.yooooo.com>\n"
+ "Return-Path: <get-some-nugenix-for-health@whatever.yooooo.comnugenix>\n"
+ "Return-Path: <get-some--for-healthnugenix@whatnugenixever.yooooo.com>\n"
+ "Return-Path: <nugenixget-some-for-health@nugenixwhatever.yooooo.com>\n\n"
+ "// No Match - Banned words only in domain\n"
+ "Return-Path: <get-some-for-health@whatever.yooooo.com>\n"
+ "Return-Path: <get-some-for-health@nugenixwhatever.yooooo.com>\n"
+ "Return-Path: <get-some-for-health@whatevernugenix.yooooo.com>\n"
+ "Return-Path: <get-some-for-health@whatever.yooooo.comnugenix>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}