re = /(?i)(?>.*?)(nugenix|cialis|somethingelse)(?>.*?@)(?!.*?(nugenix|cialis|somethingelse))/
str = '// Match
Return-Path: <get-some-nugenix-for-health@whatever.yooooo.com>
Return-Path: <get-some-nugenix@-sakana15.com>
Return-Path: <nugenix-for-health@-sakana15.com>
<anycharacters+somethingelse+anyothercharacters+@
// No match - Banned words in Sender and Domain
Return-Path: <get-some-nugenix-for-health@whatnugenixever.yooooo.com>
Return-Path: <get-some-nugenix-for-health@nugenixwhatever.yooooo.com>
Return-Path: <get-some-nugenix-for-health@whatever.yooooo.comnugenix>
Return-Path: <get-some--for-healthnugenix@whatnugenixever.yooooo.com>
Return-Path: <nugenixget-some-for-health@nugenixwhatever.yooooo.com>
// No Match - Banned words only in domain
Return-Path: <get-some-for-health@whatever.yooooo.com>
Return-Path: <get-some-for-health@nugenixwhatever.yooooo.com>
Return-Path: <get-some-for-health@whatevernugenix.yooooo.com>
Return-Path: <get-some-for-health@whatever.yooooo.comnugenix>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end