use strict;
my $str = '// Match
Return-Path: <get-some-nugenix-for-health@whatever.yooooo.com>
Return-Path: <get-some-nugenix@-sakana15.com>
Return-Path: <nugenix-for-health@-sakana15.com>
<anycharacters+somethingelse+anyothercharacters+@
// No match - Banned words in Sender and Domain
Return-Path: <get-some-nugenix-for-health@whatnugenixever.yooooo.com>
Return-Path: <get-some-nugenix-for-health@nugenixwhatever.yooooo.com>
Return-Path: <get-some-nugenix-for-health@whatever.yooooo.comnugenix>
Return-Path: <get-some--for-healthnugenix@whatnugenixever.yooooo.com>
Return-Path: <nugenixget-some-for-health@nugenixwhatever.yooooo.com>
// No Match - Banned words only in domain
Return-Path: <get-some-for-health@whatever.yooooo.com>
Return-Path: <get-some-for-health@nugenixwhatever.yooooo.com>
Return-Path: <get-some-for-health@whatevernugenix.yooooo.com>
Return-Path: <get-some-for-health@whatever.yooooo.comnugenix>';
my $regex = qr/(?i)(?>.*?)(nugenix|cialis|somethingelse)(?>.*?@)(?!.*?(nugenix|cialis|somethingelse))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}