# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ (?=.*\.jpg$)/_/gm;t' <<< "this is a test.jpg
this is a test.docx"