use strict;
my $str = 'this is a test.jpg
this is a test.docx';
my $regex = qr/ (?=.*\.jpg$)/mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";