re = / (?=.*\.jpg$)/m
str = 'this is a test.jpg
this is a test.docx'
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result