$re = '/ (?=.*\.jpg$)/m';
$str = 'this is a test.jpg
this is a test.docx';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;