const regex = / (?=.*\.jpg$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' (?=.*\\.jpg$)', 'gm')
const str = `this is a test.jpg
this is a test.docx`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);