using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\x(\d*)[^‘]*‘(\w*)[^\(]*\(([^\)]*)";
string input = @"((b’\x01’, ‘Morad’, datetime.datetime(2022, 4, 12, 15, 18, 57)),)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}