import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\x(\\d*)[^‘]*‘(\\w*)[^\\(]*\\(([^\\)]*)";
final String string = "((b’\\x01’, ‘Morad’, datetime.datetime(2022, 4, 12, 15, 18, 57)),)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}