package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\\x(\d*)[^‘]*‘(\w*)[^\(]*\(([^\)]*)`)
var str = `((b’\x01’, ‘Morad’, datetime.datetime(2022, 4, 12, 15, 18, 57)),)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}