$re = '/\\\\x(\d*)[^‘]*‘(\w*)[^\(]*\(([^\)]*)/m';
$str = '((b’\\x01’, ‘Morad’, datetime.datetime(2022, 4, 12, 15, 18, 57)),)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);