re = /\\x(\d*)[^‘]*‘(\w*)[^\(]*\(([^\)]*)/m
str = '((b’\\x01’, ‘Morad’, datetime.datetime(2022, 4, 12, 15, 18, 57)),)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end