#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?P<STRING>.*umidade.*?[=|:|])(?P<VALOR>\d.*\d)"
Local $sString = "" & @CRLF & _
"sdkjhskadjhfkhsadf" & @CRLF & _
"adfsafdsafsad" & @CRLF & _
"Umidade.............=18,9 %" & @CRLF & _
"dsafsdafsda" & @CRLF & _
"UMIDADE: 7.0%" & @CRLF & _
"sfadfsad" & @CRLF & _
"Umidade:10.4%" & @CRLF & _
"" & @CRLF & _
"Umidade :10.4%" & @CRLF & _
"---------------------"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")