import re
regex = re.compile(r"(?P<STRING>.*umidade.*?[=|:|])(?P<VALOR>\d.*\d)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("\n"
"sdkjhskadjhfkhsadf\n"
"adfsafdsafsad\n"
"Umidade.............=18,9 %\n"
"dsafsdafsda\n"
"UMIDADE: 7.0%\n"
"sfadfsad\n"
"Umidade:10.4%\n\n"
"Umidade :10.4%\n"
"---------------------")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")