using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?P<STRING>.*umidade.*?[=|:|])(?P<VALOR>\d.*\d)";
string input = @"
sdkjhskadjhfkhsadf
adfsafdsafsad
Umidade.............=18,9 %
dsafsdafsda
UMIDADE: 7.0%
sfadfsad
Umidade:10.4%
Umidade :10.4%
---------------------";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}