re = /(?P<STRING>.*umidade.*?[=|:|])(?P<VALOR>\d.*\d)/mi
str = '
sdkjhskadjhfkhsadf
adfsafdsafsad
Umidade.............=18,9 %
dsafsdafsda
UMIDADE: 7.0%
sfadfsad
Umidade:10.4%
Umidade :10.4%
---------------------'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end