import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<STRING>.*umidade.*?[=|:|])(?P<VALOR>\\d.*\\d)";
final String string = "\n"
+ "sdkjhskadjhfkhsadf\n"
+ "adfsafdsafsad\n"
+ "Umidade.............=18,9 %\n"
+ "dsafsdafsda\n"
+ "UMIDADE: 7.0%\n"
+ "sfadfsad\n"
+ "Umidade:10.4%\n\n"
+ "Umidade :10.4%\n"
+ "---------------------";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}