#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=`)\w+|(?<=^`.*[^{}\r\n]+)\b[^{}` \r\n]+"
Local $sString = "old: ^[`]\K | (?<=\G) (?>{.*?}|[^`]) \K [^{}`]+" & @CRLF & _
"`{string} with {exluded} words 12 nums`" & @CRLF & _
"oops" & @CRLF & _
"`string {with} {exluded} words 12 nums`" & @CRLF & _
"`string ww {exluded} words 12 nums`" & @CRLF & _
""quoted {string} with {exluded} words and 12 nums"" & @CRLF & _
""quoted string {with} exluded {words} and {12} nums"" & @CRLF & _
"quoted {string} with {exluded} words and 12 nums" & @CRLF & _
"quoted string {with} exluded {words} and {12} nums"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")