$re = '/(?<=`)\w+|(?<=^`.*[^{}\r\n]+)\b[^{}` \r\n]+/m';
$str = 'old: ^[`]\\K | (?<=\\G) (?>{.*?}|[^`]) \\K [^{}`]+
`{string} with {exluded} words 12 nums`
oops
`string {with} {exluded} words 12 nums`
`string ww {exluded} words 12 nums`
"quoted {string} with {exluded} words and 12 nums"
"quoted string {with} exluded {words} and {12} nums"
quoted {string} with {exluded} words and 12 nums
quoted string {with} exluded {words} and {12} nums';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);