using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=`)\w+|(?<=^`.*[^{}\r\n]+)\b[^{}` \r\n]+";
string input = @"old: ^[`]\K | (?<=\G) (?>{.*?}|[^`]) \K [^{}`]+
`{string} with {exluded} words 12 nums`
oops
`string {with} {exluded} words 12 nums`
`string ww {exluded} words 12 nums`
""quoted {string} with {exluded} words and 12 nums""
""quoted string {with} exluded {words} and {12} nums""
quoted {string} with {exluded} words and 12 nums
quoted string {with} exluded {words} and {12} nums";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}