import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=`)\\w+|(?<=^`.*[^\\{\\}\\r\\n]+)\\b[^\\{\\}` \\r\\n]+";
final String string = "old: ^[`]\\K | (?<=\\G) (?>{.*?}|[^`]) \\K [^{}`]+\n"
+ "`{string} with {exluded} words 12 nums`\n"
+ "oops\n"
+ "`string {with} {exluded} words 12 nums`\n"
+ "`string ww {exluded} words 12 nums`\n"
+ "\"quoted {string} with {exluded} words and 12 nums\"\n"
+ "\"quoted string {with} exluded {words} and {12} nums\"\n"
+ "quoted {string} with {exluded} words and 12 nums\n"
+ "quoted string {with} exluded {words} and {12} nums";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}