package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:s3\-3\-w|esetpwmdata\-1\.s3|eset\-870273198\.eu\-west\-1\.elb)\.amazonaws\.com|ext\-pwm\.eset\.com$`)
var str = `ext-pwm.eset.com
eset-870273198.eu-west-1.elb.amazonaws.com
esetpwmdata-1.s3.amazonaws.com
s3-3-w.amazonaws.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}