const regex = /^(?:s3\-3\-w|esetpwmdata\-1\.s3|eset\-870273198\.eu\-west\-1\.elb)\.amazonaws\.com|ext\-pwm\.eset\.com$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:s3\\-3\\-w|esetpwmdata\\-1\\.s3|eset\\-870273198\\.eu\\-west\\-1\\.elb)\\.amazonaws\\.com|ext\\-pwm\\.eset\\.com$', 'gmi')
const str = `ext-pwm.eset.com
eset-870273198.eu-west-1.elb.amazonaws.com
esetpwmdata-1.s3.amazonaws.com
s3-3-w.amazonaws.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}