import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:s3\\-3\\-w|esetpwmdata\\-1\\.s3|eset\\-870273198\\.eu\\-west\\-1\\.elb)\\.amazonaws\\.com|ext\\-pwm\\.eset\\.com$";
final String string = "ext-pwm.eset.com\n"
+ "eset-870273198.eu-west-1.elb.amazonaws.com\n"
+ "esetpwmdata-1.s3.amazonaws.com\n"
+ "s3-3-w.amazonaws.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}