re = /^(?:s3\-3\-w|esetpwmdata\-1\.s3|eset\-870273198\.eu\-west\-1\.elb)\.amazonaws\.com|ext\-pwm\.eset\.com$/mi
str = 'ext-pwm.eset.com
eset-870273198.eu-west-1.elb.amazonaws.com
esetpwmdata-1.s3.amazonaws.com
s3-3-w.amazonaws.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end