// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:s3\-3\-w|esetpwmdata\-1\.s3|eset\-870273198\.eu\-west\-1\.elb)\.amazonaws\.com|ext\-pwm\.eset\.com$").unwrap();
let string = "ext-pwm.eset.com
eset-870273198.eu-west-1.elb.amazonaws.com
esetpwmdata-1.s3.amazonaws.com
s3-3-w.amazonaws.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}