package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^|\D)(1\d{7})(?:\D|$)`)
var str = `a12891212a
a 12891212 a
128912120a
23456789
11233456789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}