const regex = /(?:^|\D)(1\d{7})(?:\D|$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^|\\D)(1\\d{7})(?:\\D|$)', 'gm')
const str = `a12891212a
a 12891212 a
128912120a
23456789
11233456789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}