re = /(?:^|\D)(1\d{7})(?:\D|$)/m
str = 'a12891212a
a 12891212 a
128912120a
23456789
11233456789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end